PHPのバージョンアップ問題

投稿日: カテゴリー: 未分類

キャリアからOPEN IDの移行の依頼がきており、対応しているのだが現在、全サーバーのPHPバージョンが5.xなので、以前からPHP7.xに上げたいと思っている。 しかし、10年以上前に作ったシステムなどが、複雑に絡み合って動作しているので大変である。特に「 mysql_connect 」などのMYSQL関係がPHP7では削除されて使えない。 全部作り直す訳にもいかないので、 PHP5.x でダマシダマシ使っていくしかない。今回のOPEN ID移行もPHP7.xのライブラリしかないので、PHP5.xに対応させるといった、なんとも非効率な作業を行って何とか乗り切る目処がついた。頭の痛い問題だ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です